Php 4 ou 5

Tous les problèmes liés à PHP et MySQL

Modérateurs: cheevass, subtitle, Arakis

Php 4 ou 5

Messagepar fatburner » 06 Fév 2007, 21:35

Bonjour à tous,

ayant beaucoup de soucis pour faire fonctionner installatron avec suphp...
je crois que je vais me résigner à travailler avec 1 version de php pour le moment...

Question :

Si j'installe uniquement php 5.2 cela va t il empêcher des applications web prévue pour le php4 de tourner correctement ?

Merci par avance de vos réponses :wink:
fatburner
 
Messages: 37
Inscription: 08 Avr 2006, 02:28

Messagepar cheevass » 07 Fév 2007, 00:39

Php 5.x est une amelioration de PHP 4.X acompagne de mises a jour donc ca marche, l'inverse par contre marche pas. :D

Nico
Avatar de l’utilisateur
cheevass
Administrateur
 
Messages: 188
Inscription: 04 Déc 2005, 17:39
Localisation: Alpes Maritimes

Messagepar fatburner » 07 Fév 2007, 11:07

Merci Nico pour cette info
fatburner
 
Messages: 37
Inscription: 08 Avr 2006, 02:28

Messagepar cheevass » 07 Fév 2007, 15:38

de rien ;)
Avatar de l’utilisateur
cheevass
Administrateur
 
Messages: 188
Inscription: 04 Déc 2005, 17:39
Localisation: Alpes Maritimes

Messagepar cheevass » 30 Avr 2007, 19:46

Php6 est en cour de creation, il y a des version beta il me semble, a suivre !!!
Avatar de l’utilisateur
cheevass
Administrateur
 
Messages: 188
Inscription: 04 Déc 2005, 17:39
Localisation: Alpes Maritimes

Re: Php 4 ou 5

Messagepar Avenue Du Web » 01 Mai 2007, 21:53

fatburner a écrit:Si j'installe uniquement php 5.2 cela va t il empêcher des applications web prévue pour le php4 de tourner correctement ?


Ce n'est pas tout à fait comme le dit Cheevass, c'est une évolution, mais du coup certaines fonctions et configurations ont changé, donc oui il peut y avoir des erreurs sur un site programmé en php4 qui tournerait sous php5 (pareil avec MySQL 4 et 5) voire même le site peut ne pas fonctionner du tout... C'est relativement rare, mais je l'ai déjà vu (de tête je ne me souviens plus des fonctions qui ont changé ou qui ont été supprimées mais ça doit être trouvable sur php.net), cependant la majorité des sites utilisent des CMS, blogs... tout fait qui ont mis à jour leur code quand celui-ci n'était pas compatible avec php5, donc les erreurs sont moins courantes qu'au lancement de php5 ! @+
Avenue Du Web
Administrateur
 
Messages: 286
Inscription: 26 Mai 2005, 23:55
Localisation: Rennes - France


Retourner vers PHP / MySQL

Qui est en ligne

Utilisateurs parcourant ce forum: Aucun utilisateur enregistré et 0 invités

cron